Whole document tree

Whole document tree

Mozilla 0.9.6 Release Notes
The Mozilla
At A Glance
Get Involved
License Terms
Developer Docs
Module Owners
Get the Source
Build It
Report A Bug
Bug Writing
View Source
Tree Status
New Checkins
Submit A Bug

Mozilla 0.9.6 Release Notes

These release notes describe system requirements, installation instructions, and known issues for Mozilla 0.9.6. These release notes are updated when we receive feedback, so please check back for new information. Consult our releases page to download the source and the latest version of Mozilla for your platform. Read more about customizing Mozilla and setting hidden prefs that aren't available in the prefs menu.

Use the Bugzilla Helper to report bugs. Avoid submitting a duplicate bug report by checking to see if your problem is already a known problem or one of our most frequently reported bugs. The bug reporting guidelines explain how to write a useful bug report that results in your problem being fixed.


What's New
System Requirements
Compatibility Information
Installation Notes
Known Problems
Setting Profiles
Mail and News
ChatZilla IRC Client
International Release Notes
Quality Feedback Agent
A Note For Web Developers
How To Get Involved With Mozilla
Where To Find Other Builds

What's New In This Release

  • Mozilla now displays page icons in the url bar (Expect support for shortcut icons (aka favicon) in Mozilla 0.9.7). Page icons can be defined in the html head section of a document like so:
      <LINK REL="icon" HREF="images/mozilla-16.png" TYPE="image/png">
      <LINK REL="SHORTCUT ICON" HREF="/images/global/branding/dellecomicon.ico">
  • Mozilla can now display Windows .BMP and .ICO images on all platforms.
  • Print Preview has been implemented.
  • Macintosh Page Setup has been implemented (Bug 36796)
  • Mail "prefill mail filter" support has been implemented (Bug 65761)
  • The new Search for item on the context menu lets you search for any text you highlight on a web page.
    • Select some text in browser window.
    • Right click in the browser window and a context menu will pop up.
    • Choose the Search for item and Mozilla will search for the highlighted text at your default engine.

System Requirements


  • Mac OS 8.6 or later
  • PowerPC 604e 266 MHz or faster processor, or G3/G4
  • 64 MB RAM
  • 36 MB of free hard disk space
  • Quicktime (Bugs 59059, 89720)


  • Windows 95, 98, or 98SE, Windows Me, Windows NT 4.0, Windows 2000, or Windows XP
  • Intel Pentium-class 233 MHz (or faster) processor
  • 64 MB RAM
  • 26 MB of free hard disk space


  • The following library versions (or compatible) are required: glibc 2.1, XFree86 3.3.x, GTK 1.2.x, Glib 1.2.x, Libstdc++ 2.9.0. Red Hat Linux 6.0, Debian 2.1, and SuSE 6.2 (or later) installations should work.
  • Red Hat 6.x users who want to install the Mozilla RPM must have at least version 4.0.2 of rpm installed. There is an official update to rpm from Red Hat.
  • Intel Pentium-class 233 MHz (or faster) processor
  • 64 MB of RAM
  • 26 MB of free hard disk space


  • OpenVMS Alpha V7.1 or higher
  • DECwindows MOTIF V1.2-4 or higher
  • Compaq TCP/IP Services Version 5.0 for OpenVMS or higher, MultiNet V4.3A or higher, or TCPware V5.4-3 or higher.
  • 65 MB of free hard disk space

    See the Mozilla for OpenVMS Installation Guide and Release Notes at www.openvms.compaq.com for more information.

Solaris 8

  • Solaris 8 requires the installation at least patches 109147-09, 108434-02, and 108435-02 from sunsolve.sun.com for Mozilla to run. (Bug 88205)

Compatibility Information

Visiting SSL2 and SSL3 sites while in FIPS mode may lead to a crash or failure to connect. (Bugs 106587)


If you have the Crescendo 5.01 plug-in, you must update to the latest version of Crescendo. Otherwise, Mozilla may crash at startup. (Bug 48110)

Mac OS

If you have version 4.5 (or earlier) of StuffIt Expander, you may see an error message stating that the archive is corrupted. You can ignore the message and continue with the installation. To get a newer version of StuffIt Expander, go to http://www.aladdinsys.com/expander/expander_mac_login.html

If you attempt to run Mozilla on Mac OS using a language pack (such as the Japanese Language Pack) and a Language Kit, all menu bar items will be incorrectly displayed. To resolve this problem, register Mozilla using the Language Register. For instance, if you're using the Japanese Language Pack and the Japanese Language Kit, register Mozilla as a JA application.

If you use the SmoothType control panel instead of Apple's "Smooth all fonts on screen" option in the Appearance control panel, you need SmoothType version 2.1.1 for Mozilla . Mozilla is not compatible with earlier versions of SmoothType, and some pages may be improperly drawn. To get an update, go to http://www.kaleidoscope.net/greg/smoothtype.html.


Mozilla requires glibc 2.1 or later. (Bug 44787)

If you have Red Hat Linux 6.0, you can't launch Mozilla if Java 2 is installed. The problem doesn't occur with Red Hat 6.1 or higher. (Bug 58259)

For Red Hat Linux 7, you must install the Standard C++ libraries for Red Hat 6.x compatibility. Get the package from the Red Hat 7 installation CD or download it from Red Hat. (Bug 59012)

Redhat 7 users who have problems with Java hanging should try setting the environment variable LD_ASSUME_KERNEL to "2.2.5". (Bug 84093)

To run Mozilla on SuSe Linux 6.2, you must install the libjpeg.so.62 file available here.


To install Mozilla on Solaris8 (64 bit), you must first install libstdc++. Download the Sun Netscape 6 install package and install libstdc++ from that package before installing or running Mozilla . In addition the following patches from http://sunsolve.sun.com need to be installed: 109147-09, 108434-02 108435-02. (Bug 68604)


When using a window manager from the twm family without the DecorateTransients option, popup windows such as Find, Save and Preferences will not function. To work around, set the DecorateTransients option in the window manager's rc file. (Bug 78928)

Installation Notes

Install into a new empty directory. Installing on top of previously installed builds may cause problems.

Windows Users: If you get the message, "uninstall.exe file is linked to missing export shell32.dll", delete %TEMP%\ns_temp.

Multi-user installs: To install Mozilla for multiple users on Unix, install as normal, then create the following script in your Mozilla directory, make it executable (chmod u+x <scriptname>), and run it as root.

dist_bin=`dirname $0`
touch $dist_bin/chrome/user-skins.rdf $dist_bin/chrome/user-locales.rdf
You should then be able to run that installation of Mozilla as any user who has permissions to access it.

When you install language packs and other .xpi files, downloading pauses until you click the browser's Stop button.

If you receive the message 'The program must close to allow a previous installation to complete' when launching, it means that file cleanup after an additional installation has not completed.

Suggested workarounds:

  1. In most cases, waiting a few additional seconds after the program exits will allow the cleanup process to complete and allow you to launch.
  2. Occasionally the installation process is waiting for another program to release a file the cleanup process needs. You may need to shut down other programs or reboot the computer to allow the installation process to complete.

Windows and Mac OS: It is strongly recommended that you exit all programs before running the setup program. Also, you should temporarily disable virus-detection software.

Mac OS: Mozilla will not run when the application is installed on a UFS partition. The workaround is to move the application folder to an HFS+ partition and it will
run correctly.

Mac OS: Mozilla installation requires some system extensions including QuickTime.

Mac OS: You should not restart your system with all extensions off before running Mozilla installation.


Windows and Linux: To run Java applets, you must install the Java Run Time Environment (JRE) plug-in. When using installer builds, everything should Just Work without any help.

See the Java section for more details about Java version compatibility.

Windows: If you're using the Installer build and you already have JRE 1.3.0_01 on your system Mozilla should recognize it. If it doesn't recognize it then follow the copy instructions for the zip builds.

If you're using the win32.zip or talkback.zip builds After the JRE is installed on your machine, copy NPJava130_01.dll, NPJava130_01a.dll, NPJava130_01b.dll, NPJava130_01c.dll, and NPOJI600.dll from the install directory (something like C:\Program Files\JavaSoft\JRE\1.3.0_01\bin) to your Mozilla plugins directory (something like C:\Program Files\ Mozilla 0.9.6 \bin\plugins).

Linux With tar.gz builds on Linux, after the JRE has installed, put a symlink in your mozilla0.9.6 /plugins directory to the java2/plugin/i386/ns600/libjava.oji.so directory.

With Linux RPM builds, you must install Java as the root user.

You may need to press the Stop button for the installation process to complete.

Mac OS: You must have Mac OS Runtime for Java (MRJ) version 2.2 to run Java applets with Mozilla . If you have Mac OS version 8.5 through 8.6, you may need to upgrade your version of MRJ. For an upgrade, go to the Apple MRJ update download page.


Windows, Mac and Linux: Personal Security Manager (PSM) provides security (cryptographic) features for Mozilla .

Installing on Windows

Installing Java with low disk space may cause the Installer to hang. (Bug 45067) Before you begin installing Mozilla with Java, be sure to check your disk space (see System Requirements.)

To install Mozilla by downloading the Mozilla installer, follow these steps:

  1. Click the mozilla-win32-installer.exe link to download the file to your machine.
  2. Navigate to where you downloaded the file and double-click the Mozilla program icon on your machine to begin the Setup program.
  3. Follow the on-screen instructions in the setup program. The program starts automatically the first time.

To install Mozilla by downloading the .zip file and installing manually, follow these steps:

  1. Click the mozilla-win32-talkback.zip link or the mozilla-win32.zip link to download the .zip file to your machine.
  2. Navigate to where you downloaded the file and double-click the compressed file. Note: This step assumes you already have a recent version of WinZip installed, and that you know how to use it. If not, you can get WinZip and information about the program at www.winzip.com.
  3. Extract the .zip file to a directory such as C:/Program Files/ Mozilla 0.9.6 .
  4. To start Mozilla , navigate to the directory you extracted Mozilla to and double-click the Mozilla.exe icon.

Installing on Mac OS

Note: If the downloaded file does not expand automatically you must expand the file using a program such as StuffIt Expander. Expander ships with all new Macs and comes with the default system install, so you may want to do a find in Sherlock for "StuffIt" to make sure that you don't already have it installed.

You can get StuffIt Expander from Aladdin Systems.

If you do already have Expander, you need to set it to start by default. See the immediately preceding URL for info on using Expander.

To install Mozilla by downloading the Mozilla installer, (recommended) follow these steps:

  1. Click the MacMozillaInstaller.sea.bin link to download it to your machine. By default, the download file is downloaded to your desktop compressed in .bin format. A Mozilla Installer folder is created.
  2. Double-click the Mozilla Installer folder in the Finder.
  3. Double-click the Mozilla Installer icon.
  4. Follow the on-screen instructions to complete the installation process.
  5. To start Mozilla , open the folder where you installed Mozilla and double-click the Mozilla icon.

To install Mozilla by downloading the archive file and installing manually, follow these steps:

  1. Click the mozilla-mac-*.sea.bin link to download the Mozilla binary to your machine. By default, the download file is downloaded to your desktop compressed in .sit.bin format.
  2. Double-click the mozilla-mac-*.sea.sit.bin icon on your desktop.
  3. Choose the directory where you want to install Mozilla .
  4. To start Mozilla , open the folder where you installed Mozilla and double-click the Mozilla icon.

Installing on Linux

You must run Mozilla at least once to complete autoregistration and for the component.reg file to be written to the installation directory. If a different user (other than the person who installed the product) runs the program first, a core dump will occur. (Bug 49345)

Note: To run Java applets, you must install the Java Run Time Environment (JRE) v1.3 plug-in.

Note: These instructions use the bash shell. If you're not using bash, adjust the commands accordingly.

To install Mozilla by downloading the Mozilla installer, follow these steps:

  1. Create a directory named mozilla (mkdir mozilla0.9.6 ) and change to that directory (cd mozilla0.9.6 ).
  2. Click the link to download the installer file (called mozilla-i686-pc-linux-gnu-installer.tar.gz).
  3. Change to the mozilla directory (cd mozilla0.9.6 ) and decompress the archive with the following command:
    gunzip -dc moz*.tar.gz | tar -xvf -
    (This places the installer in a subdirectory of Mozilla named mozilla-installer.)
  4. Change to the mozilla-installer directory (cd mozilla-installer) and run the installer with the ./mozilla-installer command.
  5. Follow the instructions in the install wizard for installing Mozilla .

    Note: If you have a slower machine, be aware that the installation may take some time. In this case, the installation progress may appear to hang indefinitely, even though the installation is still in process.
  6. To start Mozilla , change to the directory where you installed it and run the ./mozilla command.

To install Mozilla by downloading the .tar.gz archive file:

  1. Create a directory named " mozilla0.9.6 " (mkdir mozilla0.9.6 ) and change to that directory (cd mozilla0.9.6 ).
  2. Click the link to download the non-installer mozilla*.tar.gz file into the mozilla0.9.6 directory.
  3. Change to the mozilla directory (cd mozilla0.9.6 ) and decompress the file with the following command:
    gunzip -dc moz*.tar.gz | tar -xvf - (This creates a "mozilla" subdirectory under your mozilla0.9.6 directory.)
  4. Change to the mozilla directory (cd mozilla).
  5. Run Mozilla with the ./mozilla run script.

To hook up Mozilla complete with icon to the GNOME Panel, follow these steps:

  1. Click the GNOME Main Menu button, open the Panel menu, and then open the Add to Panel submenu and choose Launcher.
  2. Right-click the icon for Mozilla on the Panel and enter the following command:


    where directory_name is the name of the directory you downloaded Mozilla to. For example, the default directory that Mozilla suggests is /usr/local/mozilla.
  3. Type in a name for the icon, and type in a comment if you wish.
  4. Click the icon button and type in the following as the icon's location:


    where directory_name is the directory where you installed Mozilla . For example, the default directory is /usr/local/mozilla/icons/mozicon50.xpm.

Installing RPM builds: The Red Hat RPM builds are created to work with the default Red Hat 6.x and Red Hat 7.x installations. Using these RPMs on Suse requires installation of the gdk-pixbuf package. (Bug 85218)

Uninstalling Mozilla


  • Remove the mozilla0.9.6 directory where you installed Mozilla

  • Remove the ~/.mozilla directory, which contains profile information


  • Go to Settings/Control Panel/Add Remove Programs and choose Mozilla 0.9.6

Mac OS

  • Remove the folder Mozilla from the Documents folder
  • Remove the file "Mozilla Registry" from the System Folder | Preferences folder
  • Remove the file "Mozilla Versions" from the System Folder | Preferences folder
  • Remove the folder where you installed Mozilla

Files Created or Used

prefs.js (Preferences file)
cache/ (cache directory)
cookies.txt (cookies file)
*cookperm.txt (used to selectively accept/reject cookies)
FieldSchema.tbl (files for auto form filling)
SchemaConcat.tbl (files for auto form filling)
SchemaValue.tbl (files for auto form filling)
URLFieldSchema.tbl (files for auto form filling)
signons.tbl and signonsx.tbl (logins and passwords file store)

mozregistry.dat ( Mozilla registry)
mozver.dat (stores version of Mozilla components)
MozillaUninstall.exe ( Mozilla Uninstaller)
Application Data\Mozilla ( Mozilla data directory on Win98)
Mozilla Mozilla data directory on Win95

prefs.js in ~/.mozilla/[profile] (preferences file)
Cache in ~/.mozilla/[profile](cache directory)
cookies (cookies file)
*cookperm (used to selectively accept/reject cookies)
FieldSchema.tbl (files for auto form filling)
SchemaConcat.tbl (files for auto form filling)
SchemaValue.tbl (files for auto form filling)
URLFieldSchema.tbl (files for auto form filling)
signons and signonsx (logins and passwords file store)

registry ( Mozilla Registry)

prefs.js (preferences file (use))
Cache (cache directory)
cookies.txt (cookies file)
*cookperm (used to selectively accept/reject cookies)

FieldSchema.tbl (files for auto form filling)
SchemaConcat.tbl (files for auto form filling)
SchemaValue.tbl (files for auto form filling)
URLFieldSchema.tbl (files for auto form filling)

Mozilla Registry

*Note: "cookperm.txt" ("cookperm" on Unix) is a file used to selectively accept cookies from certain sites and not from others. It is used only if you set your preferences so that you see a warning before accepting cookies. To do that, set the following pref (instructions here):

  • user_pref ("network.cookie.rememberAboutCookies", true);

Known Problems


Mac OS: There is a known incompatibility between Mozilla and WebFree, a Control Panel commonly used to block HTML-based ads. When using Mozilla , disable WebFree. (Bug 13982)

Keyboard and Mouse

Double right-clicking on a page can disable the keyboard. (Bug 70812)

Linux: Keyboard shortcuts on Linux now use Ctrl instead of Alt as the modifier key, while Alt is used for menu shortcuts. If you wish to modify these shortcut keys, add the following prefs (instructions here):

user_pref("ui.key.accelKey", 18);
(This changes the accelerator key from Ctrl (17) to Alt (18).)

user_pref("ui.key.menuAccessKey", 0);
(This changes the menu access key from Alt (18) to none.)

Linux: Middle-mouse clicking in areas without links may lead to alerts popping up. (Bug 96972)

Event Handling

Wrong events are fired on FILE element. (Bug 4033)

Mouse wheel scrolling

Linux: You must have your X server properly configured to enable mousewheel scrolling. For XFree86, add a line to the Pointer section of your XF86Config files such as "ZAxisMapping 4 5". Also be sure that the Protocol line is set up correctly for your mouse.

Windows: Mousewheel scrolling does not work with all drivers. If you have problems, try updating your driver or disabling any "helper" programs that your mouse uses.

Mac OS: Mousewheel scrolling does not work with all drivers. If you have problems, try updating your driver or disabling any "helper" programs that your mouse uses.

(Mac OS 9.x ) Scroll wheel support for Kensington input devices requires Kensington MouseWorks 5.7 or higher. Version 5.7 is not yet shipping as of this writing; please check the Kensington website for updates.

Dialog Boxes and Windows

If Mozilla is locked up but doesn't seem to have crashed, make sure there are no dialog boxes still open. Close each window on your desktop one at a time and if you uncover a dialog window, dismiss it. If you have multiple desktops, repeat these steps for each desktop.

This problem may affect Linux users downloading plugins. Follow these steps to resolve the problem:

  1. Minimize the plugin download window.
  2. Click "Cancel" to dismiss the dialog box.
  3. Re-open the download window and continue downloading the plugin.

Form Manager

Form Manager is not fully implemented in the Japanese version of Mozilla .


Many Linux systems (in particular, Red Hat Linux systems) have bad Arial fonts. (Bug 46415) If many Web pages, especially those using the Arial font, look unclear, small, or hard to read, the following links explain two ways you can change your font server to get better Arial fonts:


If that doesn't work, you may be able to fix the problem by renaming or removing /usr/share/fonts/ISO8859-2. For instance, enter the following command:

mv /usr/share/fonts/ISO8859-2 /usr/share/fonts.ISO8859-2

and then log out of Linux and log back in again. You can always undo this, if necessary, by entering the following command:

mv /usr/share/fonts.ISO8859-2 /usr/share/fonts/ISO8859-2


Mozilla needs to be configured to work properly with proxies such as Junkbuster that do not support the most recent HTTP specification. By default, Mozilla tries to use HTTP 1.1. To use Mozilla with a proxy that only supports HTTP 1.0, edit the HTTP Version from 1.1 to 1.0 in Edit | Preferences | Debug | Networking. (Bug 38488)

Mozilla only accepts hostnames for manual proxies. If you migrate a Communicator 4 profile, you will need to change the settings manually. (Bug 30387) \

Setting Profiles

If you have a single profile from Communicator version 4.5 or later, that profile is automatically copied and converted for use with Mozilla . Profiles from earlier Netscape versions cannot be converted.

If you have multiple profiles to copy and convert, the profile manager dialog box appears. Click the profile you want to use and then click Start.

If problems occur during installation and your Communicator profile was not copied and converted, you can still use your profile. Launch Mozilla from the command line, adding the "-installer" option (that is, type "mozilla.exe-installer" on the command line) , or re-install Mozilla to see the profile manager dialog again.


Additional Internet Search Engines can be obtained at http://sherlock.mozdev.org

The "View Frame Source" feature is not available from the View menu; however, it is available in the context menu. To see the context menu, click the left mouse button to put the mouse pointer in the frame and then click the ri ght mouse button (Control-click on the Mac OS). (Bug 47139)

Several features of Page Information are not yet available, including: the File MIME Type, Source, Local cache file, Content length, Expires, Charset, and Security. Also, you cannot view information on frames, XML pages, or FTP pages. (Bug 52730)

Pages that appear to be rendered incorrectly may be due to standards compliance issues. See the Netscape Evangelism site for more details.

XSLT support still has bugs. (Bugs 53030, 53944, 59912, 88198, 94921 )

The scrollbar in the Preferences dialog sometimes doesn't appear after expanding categories. Workaround: collapse other categories --or, resize the dialog, if possible. (Bug 59108)

Printing web pages may not print out all pages due to table pagination problems. (Bugs 86921, 87374)

Mac and Linux: Transparent backgrounds are printed as black. (Bug 12037)

Printing newsgroup messages with images leads to a crash. (Bug 92659)

Accessing Pages

Mozilla may not be able to connect to some secure (https) IBM Web servers. This is a problem with the servers' software, not with Mozilla . (Bug 54031)

If you use "Last page visited" as your Home (starting) page, if the last page you viewed had frames, it may not be displayed correctly when you next restart Mozilla . (Bug 58613)

Accessing pages on a network requires 5 slashes (file://///). (Bug 66194)

FTP sites that use VMS may not be accessible. (Bug 84472)

Windows: Double browser window appears when opening an html or image document from the Windows environment. (Bug 59078)

Linux: You can't view hidden files or directories (such as .mozilla) using Mozilla. (Bug 39036)

Linux: Flash may crash with exported X display. (Bug 58937)

Linux: On Linux, there may be problems with ESD Audio and Flash. (Bugs 85772, 58339)

Downloading Files

Hourglass cursor, progress meter, and throbber do not stop spinning although downloading has been finished. Status bar says "Transferring data from ..." when page is done loading. (Bug 39310)

If you're unable to remove user-defined helper applications try the following:
  1. Open the Edit menu, and choose Preferences. Choose Helper Applications within the Navigator category.
  2. Select the helper application/mimetype you wish to remove from the list, and click the Remove button.
  3. Click OK to confirm.
  4. Click OK to dismiss the Preferences dialog box.
  5. Quit completely and restart Mozilla .
If the item is still listed, repeat steps 2-5. (Bug 88287) Helper application decisions may not be remembered when using Open for non-OS-defined types. A workaround for this is:
  1. Open the Edit menu, and choose Preferences. Choose Helper Applications within the Navigator category.
  2. Click the "Reset" button.
  3. Click "OK" to dismiss the Preferences dialog box.
(Bug 93173)


Bookmarks cannot be rearranged if you have sorted them. To rearrange them, select Unsorted from the View menu, or click the Name column header until the arrow disappears. (Bug 64768)

View Source

To view frame source, point to the frame and click the right mouse button (Control-click on Mac OS) and then choose View Frame Source from the context menu. (Bug 47319)

Page content generated by an online form isn't correctly reflected in the view source window.

Mac OS: The horizontal scrollbar in the View Source window might be missing. Resize the window to see the scrollbar. (Bug 56488)

Mail and News

In the Mail/News Account Settings: Server Settings dialog box, any changes you make to local directory settings won't take effect until you exit and re-start Mozilla . (Bug 2654)

Undo/Redo and Stop may not always work as expected. (Bugs 27468, 28129, and others)

Delete Message doesn't always work when you're using Next Unread Message. (Bug 44572) Try clicking the message again to enable Delete.

Biff, a feature that automatically checks your server for new mail, works only on the first account and does not work for any other accounts in the same profile. Work around: select each account's inbox once and click on Get message. (Bug 85227)

'Get All New Messages' checks the default account only, with or without passwords saved. Workaround: Select each account's Inbox and click on Get Message the first time for that session. Get All New messages should work. (Bug 80296)

Mozilla does not warn the user of a low disk space condition. (Bugs 32443, 56565) Some symptoms you may see are:

  • Copying a message to your Sent folder fails entirely or may place incomplete copy in Sent folder.
  • POP: Status text indicates there are new messages to retrieve, but no new messages appear in the Inbox. Quit Mozilla , free some disk space, re-start Mozilla , and try again.
  • IMAP: Status text indicates there are new messages to retrieve, but no new messages appear in the Inbox. Quit Mozilla , free some disk space, re-start Mozilla , and try again.

Mail account identity is not stored along with an unsent message. (Bug 59548)

Linux: You may encounter problems if you install Mozilla in a root user environment then run as another user. Problems include saving to Sent folder, Drafts, Templates or general authentication problems. (Bug 49397)

New Mail Notification Sound Doesn't Play with Non-Default Sound Chosen: When the user edit the pref.js file to inculde a non-default sound, Mozilla does not play that sound when the mail arrives. Also changing it back again to default breaks the initial default sound for that profile. Workaround: Not to change the pref.js file to edit to play any other sound and leave the default. (Bug 64462)

The Mail & Newsgroups Account Settings dialog box does not display correctly at lower monitor resolutions such as 800 by 600 or 640 by 480. If possible, increase your monitor's display resolution above 800 by 600. (Bug 82122)

AOL Mail and Netscape WebMail Accounts

Mozilla does not integrate with AOL Mail and Netscape WebMail, as Netscape 6 does. If you share your Netscape 6 profile with Mozilla, you may be able to see headers for messages in the account's Inbox if you have previously checked one of these accounts in Netscape 6, but you will be unable to interact with the messages. To access your AOL Mail, WebMail, or Netscape Instant Messenger, you need to use Netscape 6.

Receiving and Reading Messages

You may not see the message header (From, Subject, Date, To, Cc, and so forth) when you read messages. This problem often occurs when you switch mail folders or newsgroups. To see headers, resize the window or the message content pane. (Bug 39655)


In some cases you can't view more than one HTML/Web page attachment to a message in the mail window. The attachments will not all be shown or you may experience a crash when attempting to display them. (Bug 38398)

A crash may occur if you try to open or save a message attachment of a content type unknown to Mozilla . (Bug 44762)

Composing Messages

You can't forward a message that has a signature file containing the HTML tag <div class="signature">. (Bug 49484)

Address Book

To import Outlook address books, you must have the default mail client set to "Microsoft Outlook" in Microsoft Internet Explorer. Do this:

1. Launch Internet Explorer.
2. Click Tools in menu bar, then click Internet Options. The Internet Options dialog box appears.
3. Click the Programs tab and select "Microsoft Outlook" as the default e-mail client.
4. Hit OK and exit Explorer. (Bug 90206)

(Windows) You may need to try more then once before Outlook Express address books are imported successfully. (Bug 90206)

In Address Book, using "Select All" and "Delete" more than 500 cards may crash application. (Bug 90378)

Copying a large number of addresses between address books may cause crash. (Bug 82991)


If you have multiple filters configured for a mail account, incoming messages will continue to be evaluated against each filter (in the order listed in the Message Filters dialog) until a filter action of Move to Folder or Delete is executed. This differs from Communicator 4.x where any filter action would stop further filtering on a message. (Bug 30081)

Pop and IMAP

You must exit and restart Mozilla to see the effect of a change to the option: "show All IMAP mail folders" or "show only subscribed IMAP mail folders." To access this option: click the Advanced button in the Server section of the Account Settings dialog box. (Bug 38943)

When sending email from Cyrus IMAP mail accounts, you will get "The current command did not succeed. The mail server responded: Permission denied". Workaround: Redefine the special folder (sent, draft, template) under the Inbox folder. (Bug 27002)

Deleting in "Mark as deleted" mode may not work in the same way it did in Netscape Communicator 4.x. (Bug 59694)


The Subscribe dialog box may not work with news servers that require authentication. If you open a password-protected newsgroup you may be prompted more than once for the user name and password combination.


LDAP directories with ldif extensions may appear after migration from Communicator 4.x. (Bug 94645)

Mozilla may temporarily hang during LDAP autocomplete if network connectivity is broken. Specifically, if the LDAP server in question is unreachable (network connectivity problems, including taking a laptop outside a firewall), the entire app will hang when attempting to contact that browser. If the user is patient, the app will begin responding again after the TCP timeout happens, probably between 30 seconds and several minutes later. (Bug 79509)

Offline Mail

Some mail items (offline and disk preferences, offline item selection, online/offline indicators in search/history/subscribe) do not display properly. (Bug 80970)

New newsgroups can not be downloaded unless you have previously open the newsgroups and retrieved headers first. (Bug 84061)

Moving/Copying a downloaded message (while offline) will result in not being able to read the message at the new folder while you are offline. Workaround: Go online to read it, then redownload the message to have it accessible when you are offline. (Bug 78809)

If the user starts Netscape in offline mode (clicking the work offline checkbox in the profile manager), then tries to reply to a message while in offline mode, or double clicks on a message (which brings it up in a separate window), in some instances the application might crash. (Bug 92368)

Using Download and Sync on numerous newsgroups might result in not getting all the messages downloaded the first time. Workaround: Use 'Download and Sync' on one or only a few newsgroups at a time, then uncheck them once synching is complete and select another couple of newsgroups and repeat the steps. Or go online and select the Newsgroup you want to download messages from and right click and do a "Get Messages for Account" or click "Get Msg" on the toolbar. (Bug 87018)

When starting Mozilla, if you only have one profile, both of the Offline preferences for startup mode ("Ask me if I want online or offline mode", or "Use my previous online/offline state") do not work. Mozilla will always start in online mode. To go offline, from the File menu, choose Work Offline. (Bug 82487)

If the user starts Mozilla in offline mode (clicking the work offline checkbox in the profile manager), then tries to reply to a message while in offline mode, or double clicks on a message (which brings it up in a separate window), in some instances the application might crash. (Bugs 92368)

You may experience issues (only when offline) when deleting mail in either trash mode: mark as deleted or remove immediately. (Bug 101069)

When starting Mozilla, if you only have one profile, both of the Offline preferences for startup mode ("Ask me if I want online or offline mode", or "Use my previous online/offline state") do not work. Mozilla will always start in online mode. To go offline, from the File menu, choose Work Offline. (Bug 82487)



ChatZilla is not finished, but is usable if you're willing to accept a subset of the commands offered in more mature IRC clients. A large percentage of ChatZilla users experience crashes, odd behavior, rash, shortness of breath, and an urge to fix bugs. If you would like to contribute, please tell us in the netscape.public.mozilla.rt-messaging newsgroup, or send an e-mail to rginda@netscape.com.

If you are not familiar with IRC, please check out the FAQs available at www.irchelp.org.

Running ChatZilla

Start Mozilla with the -chat option to start ChatZilla, or select it from the Tasks menu.

More Info About ChatZilla

See the ChatZilla User's Guide for information on using ChatZilla. For info on building ChatZilla, click here. (Note that ChatZilla builds automatically on Windows and Mac OS).


You may not be able to simultaneously edit a document using both Composer and another editor. (Bug 37089)

You can't apply a font style across paragraphs and images. Font changes must be done within each paragraph.

Applying a font style across several words yields multiple font tags in the HTML code.

When the background color on a page is set, only the frames behind the lines of selected text are colored. Resizing the window triggers the proper repaint.

After applying a color to text, the text may appear partially highlighted.

Certain pages (such as ones that set frames) can't be edited. However, you are still able to choose the Edit Page option in the File menu for such pages. An editor window opens, but you are unable to edit the page.

Edit|PasteAs function is not functioning. (Bugs 73286, 41547)

File|Open Web Location, selecting to render in Composer does not open document in Composer. (Bug 71426)

When saving remote files, associated images are not saved. (Bugs 98550)

Switching between Normal and HTML Source mode inserts break (br) elements. (Bug 46227)

You can not print HTML Source. (Bug 82239)

Numerous shortcut keys do not function properly. (Bugs 26264, 43433, 48951, 57805, 61355, 70630, 58332, 58712, 26269, 53505, 76925, 80384, 57700, 67142, 4302, 93192, 48375)

Hourglass does not show when application is busy. (Bug 83300)

Broken image icon does not display in the application. (Bug 58646)

Some element icons do not render in Show All Tags mode. (Bug 88036)

List editing can cause nested lists to outdent to next level list. (Bug 98547)

Remove option from personal spell check dictionary does not work. (Bug 43348)

A blank window opens when clicking on the Browse button the 2nd time. Workaround: After editing the page more, if you want to view the new changes in Browser, first save the Composer file, go to the Browser window loaded before, and click the "Reload" button (or use "View | Reload" menu command). (Bug 59497)

If the cache preference is set to "Every time I view the page" and a new document is created, toolbar icons may be disabled on the toolbar and the caret may be missing. Workaround: Do not set the cache preference to "Every time I view the page." (Bug 97633)


Restoring a certificate to a smart card can take a long time. No feedback is provided while restoring a certificate to a smart card, which can take a long time since smart cards are relatively slow devices. As a result, it may appear that the restoration is not happening. (Bug 52321)

For security reasons, Mozilla does not allow connections to certain ports. To override this on a per-port basis, add a comma-separated list of ports to default/all.js (in your Mozilla installation directory). Note that this pref only works in the all.js file in the Mozilla installation directory and it affects all users of the installation. It does does not work if you add it to the prefs.js file in your personal profile directory. For example, to unblock ports 1, 3, and 7, use the following line:

pref("network.security.ports.banned.override", "1,3,7");


If you are using the Classic theme, some preference panels may be displayed incorrectly or may have missing elements. If you view a different preference panel and then return to the one you're working in, the display is corrected. (Bug 51241)

Preferences window initial size doesn't always give hints on all options available. Resize the window from its lower right corner to see them all. (Bug 53375)


Plugins installed for Communicator 4.x may not be available for Mozilla . Workaround: install these plugins in the Mozilla Plugins folder.

Microsoft Media Player file embedded in web pages may not work. (Bug 66015)

Macintosh: Mozilla now scans for plugins in the system's "Internet Plugins Folder" first.

Macintosh: Users will see the browser context menu pop up after dismissing a plugins context menu on Mac. Workaround: To remove the unwanted browser context menu, click inside the plugin area with the mouse once. (Bug 75456)

Macintosh: File menu items can only be used once for full-page plugins (like PDF) While a PDF is open in the browser window, menu items work only once. A workaround is to go BACK in history to another page (non PDF) and then access menu items. (Bug 93895)


Mozilla has been tested with all 1.3.0_* versions of the JRE, and JRE 1.3.1, and beta versions of JDK 1.4. J2SE releases previous to 1.3.0_01 will not work with Mozilla .

LiveConnect does work with Mozilla 0.9.6 . There remain some LiveConnect problems with the combination of Mozilla 0.9.6 . and JDK/JRE 1.3.X. Fixes for a number of remaining LiveConnect problems are being incorporated into JDK 1.4 and will be available when that release of JDK/JRE is available later this year.

Running J2SE in 256-color mode may cause a flicking problem.

Linux: LiveConnect support now works if you use Mozilla 0.9.6 with JRE 1.3.1. Additional LiveConnect problems are being addressed in JDK 1.4 as mentioned above.

If Java doesn't work, make sure the following is true:
On Windows:
Copy the NPOJI600.DLL from C:\JDK*\jre\bin to "\plugins" directory of your installation.
On Unix:
Make a soft link from /plugins/libjavaplugin_oji.so to /usr/java/j*/jre/plugins/i386/ns600/libjavaplugin_oji.so


On OS X, there is no "Default Downloader Plugin" (aka. the Default Plugin) and Java is not working yet. (Bug 88870)

International Release Notes


Hebrew and Arabic support does not work properly on Mac at this time. (Bug, 80577, 74125, 96305)

Mozilla has been designed to display many different languages without extra steps. The user should be able to browse and use e-mail without complicated setups or efforts when necessary fonts are available on the system.

Mozilla can be used with more than one language pack, which lets the user change the menu language and relevant URLs.

Sidebar tabs and bookmarks will not change when you choose another region. (Bug 87939)

Language/Region Packs installed in older versions of Mozilla continue to appear in the View menu after upgrading to Mozilla 0.9.6 but do not function. A user that wants to continue to use the old locale packs should keep that version by installing Mozilla 0.9.6 in a new folder. The old content packs will not appear in the Mozilla 0.9.6 View menu, but will still be available for use in the old version. Any profile set to a non-default locale in your old version will revert to the default locale in Mozilla 0.9.6. To use locale packs in Mozilla 0.9.6, it is necessary to download new locale packs via the View menu (View > Set Language/Region > Download More) or via Preferences (Edit > Preferences, expand the Appearance category, select Content Packs panel, then click Download More in the lower-right). (Bug 91721)

If you are using Chinese, Korean or Japanese language Windows 9x/ME and are having a non-start or crash problem when trying to start up Mozilla , read the Java section of the Known issues section below.

You may be unable to print out Japanese characters from Win98-J with HP Laser Jet driver (Japanese version). Workaround: Install the driver that comes with the Japanese Windows 98 installation CD. (Bug 86989)

If you have WinME-Ja, you may not be able to print to a HP LaserJet 5Si/5Si MX using the HP LaserJet 5Si/5Si MX PS printer driver In this case, you should change the driver to HP LaserJet 5Si/MX. (Bug 86989)

You may have a problem displaying characters in your language characters in older applets under Windows for Arabic, Hebrew, Japanese, Thai, Korean, Russian, Simplified Chinese or Traditional Chinese. Workaround: Install the Netscape modified version of JRE 1.3.1, available at this location: http://home.netscape.com/plugins/jvm-intl.html For more detailed discussions of differences in font.properties files between Sun and Netscape 6's special JRE distributions, Communicator 4.x compatibility issues, future plans for Sun's JRE 1.3.1, and history behind these issues, visit the following page: http://home.netscape.com/eng/intl/ns6-jrefontinfo.html. (Bug 100880)

General and Profile Manager

Windows NT/2000: If you create a non-ASCII user name (e.g. Japanese) and if it does not have the Power user or Administrator status, a new profile creation may fail. In such a case, instead of accepting the default location for profiles, choose an alternate location whose path name does not contain non-ASCII characters.

A path name that contains non-Latin 1 characters is not saved correctly. Initially they look OK but when saved, they turn into unreadable characters. A file that is defined using such characters may not be found, e.g. a mail signature file. A workaround is to use only ASCII characters for file and path names.

Profile migration does not work correctly if Communicator 4.x profile names contain 2-byte characters (e.g. Japanese) with 0x5C byte Shift_JIS character.

Shift_JIS Full-width tilde character (0x8160) and a few other Japanese symbol characters have differing correspondences to Unicode mapping tables depending on platforms. This causes characters like these to display incorrectly in some situations on Macintosh.

Linux: Under a Japanese locale, the window title in Japanese (reflecting the title of a Web page) may not show correctly if the Web page does not match the charset of the Japanese locale, e.g. Shift_JIS title on an EUC locale.

Linux: On Red Hat Linux 6.0 Japanese, the license agreement for the Japanese installer may display empty. Workaround: Click OK and move on to the next step. This problem does not occur on RH 6.1 and later.

Navigator and Composer

Mozilla does not support Dynamic Fonts. (Note: It was supported in Communicator 4.x.)

Files and directories on a local disk bearing non-Latin 1 names may not be accessed by inputting the names into the Navigator location field.

The charset attribute within a SCRIPT tag, i.e. for JavaScript, does not work. Instead JavaScript uses the charset of the document.

With the Windows 2000 IME, most of the new IME features (e.g. reconversion) are supported but some features may not work correctly.

Mac OS: Non-ASCII non-Latin 1 info stored in Internet Config will not show correctly in auto-fill fields such as "Your name" field in the Mail account setup dialog. If this happens, you can manually correct auto-filled entries.

Mac OS: The Japanese language pack or Japanese release can be used on an English Mac OS if the Japanese Language Kit has been installed on the Mac OS. (The Japanese Language support comes free with Mac OS 8.5 or later as an optional install item.) The menu and dialogs, however, will not show as Japanese unless the " Mozilla " program is registered as a Japanese language program. To do this, use the (Japanese) Language register program found in the "Apple Extras" directory.

Mac OS: The Character Coding menu check mark does not get updated promptly and shows incorrect indication of the current page encoding.


POP and Local message body search does not work with non-Latin 1 key words.

Filtering by body key has not been implemented.

The "Edit as New" menu does not correctly quote the original non-ASCII text body if the original message does not contain MIME charset information.

When you quote the original message in reply, sometimes you see the quoted text as corrupted and unreadable. If this problem occurs, check that you don't have multiple Mail folder windows open. When multiple mail folders/windows are open, the reply charset reflects the charset of the selected message in the last window opened rather than the current message from which the reply message is created. Workaround: The user can either close all Mail folder windows except the current one, or select a message in the last window opened which bears the same charset as the one that is being quoted in reply.

Character Coding menu is not effective in a standalone message view window. The standalone window also does not inherit the encoding of the Mail view window if the original message contains no MIME charset or incorrect charset information. The latter two can be overridden but its effect is not inherited into the standalone window.

Japanese Auto-detection may fail sometimes with EUC-xx and UTF-8 attachments, which lack MIME charset information.

The Character Coding menu cannot correct the thread pane display of non-MIME encoded headers. If the message displayed lacks MIME charset information, the thread pane display obeys the default message display charset set in the Preferences dialog box under "Mail & Newsgroups | Message Display | Languages". Correctly setting this option to the charset most often used in the user's mail viewing helps avoid display problem of this type.

Mac OS and Linux: View Page Source does not work for viewing a message source when the Auto-Detect (All) is on. To use this function in Mail, turn off the Auto-Detect (All) from the Character Coding submenu of the View menu.


You may see an extraneous vertical bar or a question mark in the window title display of a header subject line. This is a misinterpreted Tab character sent from an IMAP server as part of a line folding sequence. This problem does not occur under a POP mail account.


Some cases have been reported in which Windows 9x/ME Japanese users have a problem starting Mozilla when there is a prior installation of older JDK or JRE under the operating system in use. The JRE 130_01 that ships with Mozilla contains many fixes since the official release of JRE 1.3. If you are using an older version of JRE 1.3 or the US version of JRE 1.3 under Japanese Windows, you may experience this non-start problem.

To determine if the non-starting problem is due to Java installation, follow these steps:

    1. Locate the Plugins directory (which is found in the same directory as the Mozilla executable).
    2. Remove all the Java plugin files from the Plugins directory, i.e. the files whose names begin with "npjava...". Remove also the NPOJI600.dll file if you find one. Back them up in another directory so that you can restore them later.
    3. Restart Mozilla . If Mozilla starts, then you have a Java related non-start problem.

If you have the Java problem as described above or want to install updated JRE 130_01 shipped with Mozilla , follow these steps (Note: This type of problem has not been reported for Windows NT4/2000, but if you experience this problem on the latter two platforms, follow these steps for those platforms also):

    1. Click the Start button, open the Settings menu, and choose Control Panel.
    2. Double-click the Add/Remove Programs icon and select the Install/Uninstall tab.
    3. Locate the old JRE installation (Java Runtime Environment) and delete it.
    4. Run the Mozilla installer and choose either "Complete" or "Custom" installation making sure that Java is installed in the latter option. (Note that the "Typical" install does not install the JRE package but if there is an existing JDK or JRE on the operating system, the installer copies Java plugin files and place them into Mozilla 's Plugins directory.) This will install the latest version of JRE 130_01, which works with Mozilla .

Mac OS and Linux: Display of non-ASCII characters (particularly Chinese/Korean/Japanese) in applets may not work without correct font settings in font.properties file.

Using the Quality Feedback Agent with Automatic Proxy Configuration

Windows: If you are using automatic proxy configuration, and you want to use the Full Circle Talkback Quality Feedback Agent to send incident reports to mozilla.org , you need to replace the talkback.ini file with one that contains the appropriate proxy configuration information. Follow these steps to do so:

  1. If you are using an HTTP proxy, or both an HTTP and SOCKS proxy, create a file named talkback.ini, containing the following three lines, using your proxy host name, domain, and port:
  2. UseUserHTTPProxyInfo=1

    where xxxx is your proxy port number.

    If you are using a SOCKS Proxy, create a file with these three lines:


    where xxxx is your SOCKS port number.

  3. Replace the existing talkback.ini file with the version you created.

On Windows 95 and Windows NT systems, copy the talkback.ini file to the following directory location within the directory that contains the Mozilla.exe file: \Fullsoft\data\talkback.ini

Setting User Preferences using prefs.js

Mozilla is very configurable, and so there is not room in the UI for controls to change all the preferences. If you need to change a preference for which there is no UI, you will need to edit your preferences file, prefs.js. These instructions detail how to do this.

This file is read in by Mozilla on startup, and rewritten on exit, so if you modify the file while Mozilla is running, your changes will get overwritten. So, first you must quit Mozilla completely (including quitting Quick Launch if you are on Windows). Once you have backed it up, open the prefs.js file in your profile directory and add the correct line or lines, which should have the form:

user_pref("foo.bar.baz", "somevalue");
user_pref("foo.bar.baz", true);
for on/off preferences. When you have finished editing, restart Mozilla.

Your profile directory is located at:

  • ~/.mozilla/<profilename>/xxxxxxxx.slt/ on Unix
  • %WINDOWS%\Application Data\Mozilla\Profiles\<profilename>\xxxxxxxx.slt\ on Windows
  • Documents:Mozilla:Profiles:<profilename>:xxxxxxxx.slt: on MacOS.
xxxxxxxx.slt is a randomly-generated directory name. It's an important security feature.

A Note For Web Developers

For a list of known issues with support for Web standards (HTML 4.01, CSS1/2, DOM1/ 2, XML, RDF), JavaScript, Java, and Plug-ins in Mozilla , see the following document, which will soon be updated to reflect the latest changes in Mozilla: http://developer.netscape.com/docs/technote/gecko/n6release.html

How To Get Involved With Mozilla

  • Join us on Bug Day. If you want to help test Mozilla, but don't know where to start, join us on Wednesdays at 3:00PM PST on the #mozillazine IRC channel on irc.mozilla.org. If you are running a recent Mozilla and have installed ChatZilla, hit this. There you can meet friendly Mozillans who can help you learn the process and get you started.
  • Join the BugAThon. If you can script, you can help simplify test cases.
  • To become even more involved, check out these suggested starting points.

Where To Find Other Builds

  • Download the latest major release of Mozilla from mozilla.org.
  • Download today's build of Mozilla from the mozilla.org FTP site.
  • Learn how to build Mozilla yourself.
Copyright © 1998-2002 The Mozilla Organization.
Last modified January 31, 2002.
Document History.