Whole document tree

Whole document tree

Mozilla 1.0 Release Candidate 2 Release Notes
The Mozilla
At A Glance
Get Involved
License Terms
Developer Docs
Module Owners
Get the Source
Build It
Report A Bug
Bug Writing
View Source
Tree Status
New Checkins
Submit A Bug

Mozilla 1.0 Release Candidate 2 Release Notes

These release notes describe system requirements, installation instructions, and known issues for Mozilla 1.0 Release Candidate 2. These release notes are updated when we receive feedback, so please check back for new information. Consult our releases page to download the source and the latest version of Mozilla for your platform. See our end user documentation section for more information on using and configuring Mozilla.

Use the Bugzilla Helper to report bugs. Avoid submitting a duplicate bug report by checking to see if your problem is already a known problem or one of our most frequently reported bugs. The bug reporting guidelines explain how to write a useful bug report that results in your problem being fixed.


What's New
New Additions to the Release Notes
System Requirements
Compatibility Information
Installation Notes
Files Created or Used
Known Problems
Setting Profiles
Mail and News
ChatZilla IRC Client
JavaScript Debugger
International Release Notes
Quality Feedback Agent
A Note For Web Developers
How To Get Involved With Mozilla
Where To Find Other Builds

What's New In This Release

  • A security vulnerability reported in Mozilla by GreyMagic Software has now been fixed. For more information see the mozilla.org statement.
  • Fifteen of our most frequently encountered crashes have been fixed. You can help us find any that are left by banging on Mozilla and sending in those TalkBack crash reports.
  • Ten of our most frequently encountered application freezes have been fixed (including the dreaded bug 96504 on Linux).
  • We finally support CSS2 :hover the way web developers want us to. (Bug bug 5693)
  • It is now possible to install colormap on 8 bit displays using -install. (Bug 22337)
  • Cookies can now be disabled for Mozilla Mail. (Bug 22994)
  • You can now enable in preferences HTTP 1.1 pipelining (not on by default). (Bug 93054)
  • Mozilla is working again on Mac OS 8.5 and 8.6. The startup hang experienced in RC1 is fixed.

System Requirements


  • Mac OS 8.5 or later
  • PowerPC 604e 266 MHz or faster processor, or G3/G4
  • 64 MB RAM
  • 36 MB of free hard disk space
  • QuickTime (Bugs 59059)


  • Windows 95, 98, or 98SE, Windows Me, Windows NT 4.0, Windows 2000, or Windows XP
  • Intel pentium class 233 MHz (or faster) processor
  • 64 MB RAM
  • 26 MB of free hard disk space


  • The following library versions (or compatible) are required: glibc 2.1, XFree86 3.3.x, GTK 1.2.x, Glib 1.2.x, Libstdc++ 2.9.0. Red Hat Linux 6.0, Debian 2.1, and SuSE 6.2 (or later) installations should work.
  • Red Hat 6.x users who want to install the Mozilla RPM must have at least version 4.0.2 of rpm installed. There is an official update to rpm from Red Hat.
  • Intel pentium class 233 MHz (or faster) processor
  • 64 MB of RAM
  • 26 MB of free hard disk space


  • OpenVMS Alpha V7.1 or higher
  • DECwindows MOTIF V1.2-4 or higher
  • Compaq TCP/IP Services Version 5.0 for OpenVMS or higher, MultiNet V4.3A or higher, or TCPware V5.4-3 or higher.
  • 65 MB of free hard disk space

    See the Mozilla for OpenVMS Installation Guide and Release Notes at www.openvms.compaq.com for more information.

Solaris 8

  • Solaris 8 requires the installation at least patches 109147-09, 108434-02, and 108435-02 from sunsolve.sun.com for Mozilla to run. (Bug 88205)

Compatibility Information

If you are running McAfee's WebScanX, you may experience crashes at startup. Please disable the product and see if it prevents the problem. If so, please contact McAfee for a solution. (Bug 107882)

To use MathML in Mozilla , you must install the appropriate TeX fonts. See http://www.mozilla.org/projects/mathml/fonts/ for information on installing the appropriate fonts. (Bug 134849)

McAfee virus scanner has an advanced option, not enabled by default, to turn on a Web-scanning feature. This feature intersects all winsock2 system calls and may cause Mozilla to crash. It is recommended that disable this feature before using Mozilla. (Bug 111316)

Visiting SSL2 and SSL3 sites while in FIPS mode may lead to a crash or failure to connect. (Bugs 106587)


If you have the Crescendo 5.01 plug-in, you must update to the latest version of Crescendo. Otherwise, Mozilla may crash at startup. (Bug 48110)

Mac OS

If you have version 4.5 (or earlier) of StuffIt Expander, you may see an error message stating that the archive is corrupted. You can ignore the message and continue with the installation. To get a newer version of StuffIt Expander, go to http://www.aladdinsys.com/expander/expander_mac_login.html

If you attempt to run Mozilla on Mac OS using a language pack (such as the Japanese Language Pack) and a Language Kit, all menu bar items will be incorrectly displayed. To resolve this problem, register Mozilla using the Language Register. For instance, if you're using the Japanese Language Pack and the Japanese Language Kit, register Mozilla as a JA application.

If you use the SmoothType control panel instead of Apple's "Smooth all fonts on screen" option in the Appearance control panel, you need SmoothType version 2.1.1 for Mozilla . Mozilla is not compatible with earlier versions of SmoothType, and some pages may be improperly drawn. To get an update, go to http://www.kaleidoscope.net/greg/smoothtype.html.


Mozilla requires glibc 2.1 or later. (Bug 44787)

If you have Red Hat Linux 6.0, you can't launch Mozilla if Java 2 is installed. The problem doesn't occur with Red Hat 6.1 or higher. (Bug 58259)

For Red Hat Linux 7, you must install the Standard C++ libraries for Red Hat 6.x compatibility. Get the package from the Red Hat 7 installation CD or download it from Red Hat. (Bug 59012)

Red Hat 7 users who have problems with Java hanging should try setting the environment variable LD_ASSUME_KERNEL to "2.2.5". (Bug 84093)

To run Mozilla on SuSE Linux 6.2, you must install the libjpeg.so.62 file available here.


To install Mozilla on Solaris 8 (64 bit), you must first install libstdc++. Download the Sun Netscape 6 install package and install libstdc++ from that package before installing or running Mozilla . In addition the following patches from http://sunsolve.sun.com need to be installed: 109147-09, 108434-02 108435-02. (Bug 68604)


When using a window manager from the twm family without the DecorateTransients option, pop-up windows such as Find, Save and Preferences will not function. To work around, set the DecorateTransients option in the window manager's rc file. (Bug 78928)

Installation Notes

Install into a new empty directory. Installing on top of previously installed builds may cause problems.

Windows Users: If you get the message, "uninstall.exe file is linked to missing export shell32.dll", delete %TEMP%\ns_temp.

Multi-user installs: To install Mozilla for multiple users on Unix, install as normal, then create the following script in your Mozilla directory, make it executable (chmod u+x <scriptname>), and run it as root.

dist_bin=`dirname $0`
touch $dist_bin/chrome/user-skins.rdf $dist_bin/chrome/user-locales.rdf
You should then be able to run that installation of Mozilla as any user who has permissions to access it.

When you install language packs and other .xpi files, downloading pauses until you click the browser's Stop button.

If you receive the message 'The program must close to allow a previous installation to complete' when launching, it means that file cleanup after an additional installation has not completed.

Suggested workarounds:

  1. In most cases, waiting a few additional seconds after the program exits will allow the cleanup process to complete and allow you to launch.
  2. Occasionally the installation process is waiting for another program to release a file the cleanup process needs. You may need to shut down other programs or reboot the computer to allow the installation process to complete.

Windows and Mac OS: It is strongly recommended that you exit all programs before running the setup program. Also, you should temporarily disable virus detection software.

Mac OS X: Mozilla will not run when the application is installed on a UFS partition. The workaround is to move the application folder to an HFS+ partition and it will run correctly.

Mac OS: Mozilla installation requires some system extensions including QuickTime.

Mac OS: You should not restart your system with all extensions off before running Mozilla installation.


Windows and Linux: To run Java applets, you must install the Java Run Time Environment (JRE) plug-in.
Windows: When using installer builds, everything should Just Work without any help.

See the Java section for more details about Java version compatibility.

Windows: If you're using the Installer build and you already have JRE 1.3.0_01 on your system Mozilla should recognize it. If it doesn't recognize it then follow the copy instructions for the zip builds.

If you're using the win32.zip or talkback.zip builds After the JRE is installed on your machine, copy NPJava130_01.dll, NPJava130_01a.dll, NPJava130_01b.dll, NPJava130_01c.dll, and NPOJI610.dll from the install directory (something like C:\Program Files\JavaSoft\JRE\1.3.0_01\bin) to your Mozilla plugins directory (something like C:\Program Files\ Mozilla 1.0.RC2 \bin\plugins).

Linux With tar.gz builds on Linux, after the JRE has installed, put a symlink to java2/plugin/i386/ns610/libjava.oji.so in your mozilla1.0.RC2 plugins/ directory.

With Linux RPM builds, you must install Java as the root user.

You may need to press the Stop button for the installation process to complete.

Mac OS: You must have Mac OS Runtime for Java (MRJ) version 2.2 to run Java applets with Mozilla . If you have Mac OS version 8.5 through 8.6, you may need to upgrade your version of MRJ. For an upgrade, you could go to versiontracker's MRJ page.


If you enable TLS in your SSL preferences and a web site server is "TLS intolerant," the client will fall back to using SSL3. However, if you have selected to use a proxy for secure connections, the browser will not be able to reach a "TLS intolerant" web site. (Bug 87902)

If you are using more than one profile, and sending signed and/or encrypted email, or visit a web site requiring your personal certificate, it is recommended that you disable Quick Launch to prevent errors. In Mozilla, Quick Launch is turned off by default so you won't see this problem unless you turned on Quick Launch during installation or in your preferences. (Bug 125561)

  • Certificates deleted from the Certificate Manager will still appear until you restart Mozilla. (Bug 129067)

    Revoked certifcates using OCSP may still appear in the Certificate Manager verified as "True". (Bug 91530)

    If you set the memory cache to 0, you should set the disk cache to 0 also. Otherwise, you will not be able to view https:// (secure) web sites.

    Windows, Mac OS and Linux: Personal Security Manager (PSM) provides security (cryptographic) features for Mozilla .

    Installing on Windows

    Installing Java with low disk space may cause the Installer to hang. (Bug 45067) Before you begin installing Mozilla with Java, be sure to check your disk space (see System Requirements.)

    To install Mozilla by downloading the Mozilla installer, follow these steps:

    1. Click the mozilla-win32-installer.exe link to download the file to your machine.
    2. Navigate to where you downloaded the file and double click the Mozilla program icon on your machine to begin the Setup program.
    3. Follow the on-screen instructions in the setup program. The program starts automatically the first time.

    To install Mozilla by downloading the .zip file and installing manually, follow these steps:

    1. Click the mozilla-win32-talkback.zip link or the mozilla-win32.zip link to download the .zip file to your machine.
    2. Navigate to where you downloaded the file and double click the compressed file. Note: This step assumes you already have a recent version of WinZip installed, and that you know how to use it. If not, you can get WinZip and information about the program at www.winzip.com.
    3. Extract the .zip file to a directory such as C:/Program Files/ Mozilla 1.0.RC2 .
    4. To start Mozilla , navigate to the directory you extracted Mozilla to and double click the Mozilla.exe icon.

    Installing on Mac OS

    Note: If the downloaded file does not expand automatically you must expand the file using a program such as StuffIt Expander. Expander ships with all new Macs and comes with the default system install, so you may want to do a find in Sherlock for "StuffIt" to make sure that you don't already have it installed.

    You can get StuffIt Expander from Aladdin Systems.

    If you do already have Expander, you need to set it to start by default. See the immediately preceding URL for info on using Expander.

    To install Mozilla by downloading the Mozilla installer, (recommended) follow these steps:

    1. Click the MacMozillaInstaller.sea.bin link to download it to your machine. By default, the download file is downloaded to your desktop compressed in .bin format. A Mozilla Installer folder is created.
    2. Double click the Mozilla Installer folder in the Finder.
    3. Double click the Mozilla Installer icon.
    4. Follow the on-screen instructions to complete the installation process.
    5. To start Mozilla , open the folder where you installed Mozilla and double click the Mozilla icon.

    To install Mozilla by downloading the archive file and installing manually, follow these steps:

    1. Click the mozilla-mac-*.sea.bin link to download the Mozilla binary to your machine. By default, the download file is downloaded to your desktop compressed in .sit.bin format.
    2. Double click the mozilla-mac-*.sea.sit.bin icon on your desktop.
    3. Choose the directory where you want to install Mozilla .
    4. To start Mozilla , open the folder where you installed Mozilla and double click the Mozilla icon.

    Installing on Linux

    If the Mozilla installer dies immediately with the error message "getcwd: Function not implemented", then download a Mozilla tarball build instead. (Bug 101016)

    You must run Mozilla at least once to complete autoregistration and for the component.reg file to be written to the installation directory. If a different user (other than the person who installed the product) runs the program first, a core dump will occur. (Bug 49345)

    Note: To run Java applets, you must install the Java Run Time Environment (JRE) v1.3 plug-in.

    Note: These instructions use the bash shell. If you're not using bash, adjust the commands accordingly.

    To install Mozilla by downloading the Mozilla installer, follow these steps:

    1. Create a directory named mozilla (mkdir mozilla1.0.RC2 ) and change to that directory (cd mozilla1.0.RC2 ).
    2. Click the link to download the installer file (called mozilla-i686-pc-linux-gnu-installer.tar.gz).
    3. Change to the mozilla directory (cd mozilla1.0.RC2 ) and decompress the archive with the following command:
      gunzip -dc moz*.tar.gz | tar -xvf -
      (This places the installer in a subdirectory of Mozilla named mozilla-installer.)
    4. Change to the mozilla-installer directory (cd mozilla-installer) and run the installer with the ./mozilla-installer command.
    5. Follow the instructions in the install wizard for installing Mozilla .

      Note: If you have a slower machine, be aware that the installation may take some time. In this case, the installation progress may appear to hang indefinitely, even though the installation is still in process.
    6. To start Mozilla , change to the directory where you installed it and run the ./mozilla command.

    To install Mozilla by downloading the .tar.gz archive file:

    1. Create a directory named " mozilla1.0.RC2 " (mkdir mozilla1.0.RC2 ) and change to that directory (cd mozilla1.0.RC2 ).
    2. Click the link to download the non-installer mozilla*.tar.gz file into the mozilla1.0.RC2 directory.
    3. Change to the mozilla directory (cd mozilla1.0.RC2 ) and decompress the file with the following command:
      gunzip -dc moz*.tar.gz | tar -xvf - (This creates a "mozilla" subdirectory under your mozilla1.0.RC2 directory.)
    4. Change to the mozilla directory (cd mozilla).
    5. Run Mozilla with the ./mozilla run script.

    To hook up Mozilla complete with icon to the GNOME Panel, follow these steps:

    1. Click the GNOME Main Menu button, open the Panel menu, and then open the Add to Panel sub-menu and choose Launcher.
    2. Right click the icon for Mozilla on the Panel and enter the following command:


      where directory_name is the name of the directory you downloaded Mozilla to. For example, the default directory that Mozilla suggests is /usr/local/mozilla.
    3. Type in a name for the icon, and type in a comment if you wish.
    4. Click the icon button and type in the following as the icon's location:


      where directory_name is the directory where you installed Mozilla . For example, the default directory is /usr/local/mozilla/icons/mozicon50.xpm.

    Installing RPM builds: The Red Hat RPM builds are created to work with the default Red Hat 6.x and Red Hat 7.x installations. Using these RPMs on SuSE requires installation of the gdk-pixbuf package. (Bug 85218)

    Uninstalling Mozilla


    • Remove the mozilla1.0.RC2 directory where you installed Mozilla
    • Remove the ~/.mozilla directory, which contains profile information


    • Go to Settings/Control Panel/Add Remove Programs and choose Mozilla 1.0.RC2

    Mac OS 9

    • Remove the folder Mozilla from the Documents folder
    • Remove the file "Mozilla Registry" from the System Folder | Preferences folder
    • Remove the file "Mozilla Versions" from the System Folder | Preferences folder
    • Remove the folder where you installed Mozilla

    Mac OS X

    • Remove the folder Mozilla from your Documents folder inside your home Users directory
    • Remove the file "Mozilla Registry" from /Users/yourusername/Library/Preferences
    • Remove the file "Mozilla Versions" from /Users/yourusername/Library/Preferences
    • Remove the folder where you installed Mozilla

    Files Created or Used

    Mozilla stores data associated with you in a place called a profile. Profiles contain your preferences, mail folders, history, cookies, address books and other important data. Here is a list of these files.

    Cache Cache files (temporary internet files). Enter about:cache in the URL bar for more information.
    chrome User defined styles and installed themes and applications
    ImapMailIMAP mail
    MailLocal Folders and POP3 mail
    NewsUsenet Newsgroups
    somenumber.s Password data
    somenumber.w Fill Form data
    Application Registry. Files where Mozilla keeps track of your profiles.
    abook.mab Personal addressbook
    bookmarks.html Bookmarks
    cert7.db Client Certificate database
    Component Registry
    Mozilla XPCOM registry. Files where Mozilla keeps track of its components.
    cookies.txt Cookies
    cookperm.txt Cookie and Image permissions
    history.dat URL history
    history.mab Collected Address book
    key3.db Key database
    localstore.rdf Defines default windows settings. Saved persistent values. Info about toolbars, size, positions, etc
    mimeTypes.rdf Defines recognized file mime types for the Helper App
    panacea.dat Mail folder cache. Summary of certain fields in all the mail/news databases, mostly used to display the folder pane
    panels.rdf Information about which panels that will be displayed in the sidebar
    prefs.js All your settings. Enter about:config in the URL bar for more information.
    search.rdf Information about your search plugins in the sidebar
    secmod.db Security module database
    URL.tbl Excluded Fill Form data sites
    user.js User setting which will be written into prefs.js after Mozilla is started
    xpti.dat XPCOM typelib information catalog
    XUL FastLoad File
    XUL fast load file. Contains precompiled chrome and JavaScript.
    At some time Mozilla invalidated your XUL fast load file. These are the files. You can just delete them if you don't want to debug them.
    (Windows) Stores component version
    (Windows) Uninstaller executable file
    Other Files
    *.msf Mail Summary Files. Contains summary of the mail folder. Located in the ImapMail and Mail directories.
    rules.dat Contains the Mail Filters for the current server. Located in the ImapMail and Mail directories.
    *.rc Contains subscribe newsgroups for the current server. Located in the News directory.
    hostinfo.dat Contains all the newsgroups available for the current server. Located in the News directory.

    Profile Locations

    Windows %USERPROFILE%\Application Data\Mozilla\Profiles\[Profile Name]\[random string].slt\
    Windows 2000 C:\Documents and Settings\[Windows Login Name]\Application Data\Mozilla\Profiles\[Profile Name]\[random string].slt\
    Windows 95 & Windows 98 C:\Windows\Application Data\Mozilla\Profiles\[Profile Name]\[random string].slt\
    Mac OS 9 Documents:Mozilla:[User Profile]:[random string].slt:
    Mac OS X ~/Library/Application\ Support/org.mozilla.Mozilla/Profiles/[Profile Name]/[random string].slt/
    Linux ~/.mozilla/[Profile Name]/[random string].slt/

    Known Problems


    Mac OS: There is a known incompatibility between Mozilla and WebFree, a Control Panel commonly used to block HTML based ads. When using Mozilla , disable WebFree. (Bug 13982)

    Linux: Mozilla does not recognize changes in DNS servers while running. PPP and VPN users should restart the browser (or try telling the browser to go offline and then online) after connecting to a different network. (Bug 64857)

    Keyboard and Mouse

    Double right clicking on a page can disable the keyboard. (Bug 70812)

    Linux: Keyboard shortcuts on Linux now use Ctrl instead of Alt as the modifier key, while Alt is used for menu shortcuts. If you wish to modify these shortcut keys, add the following prefs (instructions here):

    user_pref("ui.key.accelKey", 18);
    (This changes the accelerator key from Ctrl (17) to Alt (18).)

    user_pref("ui.key.menuAccessKey", 0);
    (This changes the menu access key from Alt (18) to none.)

    Linux: Clicking the middle mouse buttonin areas without links may lead to alerts popping up. (Bug 96972)

    Event Handling

    Wrong events are fired on FILE element. (Bug 4033)

    Mouse wheel scrolling

    Linux: You must have your X server properly configured to enable mousewheel scrolling. For XFree86, add a line to the Pointer section of your XF86Config files such as "ZAxisMapping 4 5". Also be sure that the Protocol line is set up correctly for your mouse.

    Windows: Mousewheel scrolling does not work with all drivers. If you have problems, try updating your driver or disabling any "helper" programs that your mouse uses.

    Mac OS: Mousewheel scrolling does not work with all drivers. If you have problems, try updating your driver or disabling any "helper" programs that your mouse uses.

    (Mac OS 9.x ) Scroll wheel support for Kensington input devices requires Kensington MouseWorks 5.7 or higher. Version 5.7 is now shipping; see the Kensington website.

    Dialog Boxes and Windows

    If Mozilla is locked up but doesn't seem to have crashed, make sure there are no dialog boxes still open. Close each window on your desktop one at a time and if you uncover a dialog window, dismiss it. If you have multiple desktops, repeat these steps for each desktop.

    This problem may affect Linux users downloading plugins. Follow these steps to resolve the problem:

    1. Minimize the plugin download window.
    2. Click "Cancel" to dismiss the dialog box.
    3. Reopen the download window and continue downloading the plugin.

    Form Manager

    Form Manager is not fully implemented in the Japanese version of Mozilla .


    Many Linux systems (in particular, Red Hat Linux systems) have bad Arial fonts. (Bug 46415) If many Web pages, especially those using the Arial font, look unclear, small, or hard to read, the following links explain two ways you can change your font server to get better Arial fonts:


    If that doesn't work, you may be able to fix the problem by renaming or removing /usr/share/fonts/ISO8859-2. For instance, enter the following command:

    mv /usr/share/fonts/ISO8859-2 /usr/share/fonts.ISO8859-2

    and then log out of Linux and log back in again. You can always undo this, if necessary, by entering the following command:

    mv /usr/share/fonts.ISO8859-2 /usr/share/fonts/ISO8859-2


    Mozilla needs to be configured to work properly with proxies such as Junkbuster that do not support the most recent HTTP specification. By default, Mozilla tries to use HTTP 1.1. To use Mozilla with a proxy that only supports HTTP 1.0, edit the HTTP Version from 1.1 to 1.0 in Edit | Preferences | Debug | Networking. (Bug 38488)

    Mozilla only accepts hostnames for manual proxies. If you migrate a Communicator 4 profile, you will need to change the settings manually. Communicator 4 allowed URL's in manual configuration, but Mozilla does not. If you migrate a profile configured this way, you will need to change the URL to a hostname and port number. (Bug 30387)

    Setting Profiles

    If you have a single profile from Communicator version 4.5 or later, that profile is automatically copied and converted for use with Mozilla . Profiles from earlier Netscape versions cannot be converted.

    If you have multiple profiles to copy and convert, the profile manager dialog box appears. Click the profile you want to use and then click Start.

    If problems occur during installation and your Communicator profile was not copied and converted, you can still use your profile. Launch Mozilla from the command line, adding the "-installer" option (that is, type "mozilla.exe -installer" on the command line) , or reinstall Mozilla to see the profile manager dialog again.


    While using tabbed browser, visiting a page which calls the window.close() method of JavaScript, the entire window will close, as opposed to the tab which contained the code. (Bug 103452) As a workaround, you may wish to disable window.close() for all websites by setting the following preference:
    user_pref("capability.policy.default.Window.close", "noAccess");

    Additional Internet Search Engines can be obtained at http://mycroft.mozdev.org/

    The "View Frame Source" feature is not available from the View menu; however, it is available in the context menu. To see the context menu, click the left mouse button to put the mouse pointer in the frame and then click the right mouse button (Control click on the Mac OS). (Bug 47139)

    Pages that appear to be rendered incorrectly may be due to standards compliance issues. See the Netscape Evangelism and Mozilla Evangelism sites for more details.

    Accessing Pages

    Mozilla may not be able to connect to some secure (HTTPS) IBM Web servers. This is a problem with the servers' software, not with Mozilla . (Bug 54031)

    If you use "Last page visited" as your Home (starting) page, if the last page you viewed had frames, it may not be displayed correctly when you next restart Mozilla . (Bug 58613)

    Accessing pages with a Uniform Naming Convention (UNC) requires 5 slashes (file://///). (Bug 66194)

    Linux: Flash may crash with exported X display. (Bug 58937)

    Linux: On Linux, there may be problems with ESD Audio and Flash. (Bugs 85772)

    Downloading Files

    Hourglass cursor, progress meter, and throbber do not stop spinning although downloading has been finished. Status bar says "Transferring data from ..." when page is done loading. (Bug 39310)

    If you're unable to remove user-defined helper applications try the following:
    1. Open the Edit menu, and choose Preferences. Choose Helper Applications within the Navigator category.
    2. Select the helper application/mimetype you wish to remove from the list, and click the Remove button.
    3. Click OK to confirm.
    4. Click OK to dismiss the Preferences dialog box.
    5. Quit completely and restart Mozilla .
    Helper application decisions may not be remembered when opening files which aren't defined by the OS. A workaround for this is:
    1. Open the Edit menu, and choose Preferences. Choose Helper Applications within the Navigator category.
    2. Click the "Reset" button.
    3. Click "OK" to dismiss the Preferences dialog box.
    (Bug 93173)


    Bookmarks cannot be rearranged if you have sorted them. To rearrange them, select Unsorted from the View menu, or click the Name column header until the arrow disappears. (Bug 64768)

    View Source

    To view frame source, point to the frame and click the right mouse button (Control click on Mac OS) and then choose View Frame Source from the context menu. (Bug 47319)

    Mac OS: The horizontal scrollbar in the View Source window might be missing. Resize the window to see the scrollbar. (Bug 56488)

    Mail and News

    Moving or copying a labeled message will not retain label in destination when filing across accounts:

    1. IMAP to any other account (including Local Folders): Message labels are lost.
    2. POP to POP (including Local Folders) is OKAY.
    3. POP to IMAP: Message labels are lost.
    4. Copy Newsgroup messages to any account: Message labels are lost. (Bug 133795)

    In plain text mail and mail subject headers, the Euro character (€) may be represented by its official transliteration, "EUR". This happens when the message is encoded with a charset such as ISO-8859-1 which does not support the Euro character. To ensure the proper transmission of the Euro character, set the character encoding of your message to Western (ISO-8859-15), Unicode (UTF-8) or another encoding which supports the Euro character. For a more detailed explanation, read this news article for more. See bug 109342 for the discussion on which encoding should be the default encoding for users of the Western script.

    In the Mail/News Account Settings: Server Settings dialog box, any changes you make to local directory settings won't take effect until you exit and restart Mozilla . (Bug 2654)

    Biff, a feature that automatically checks your server for new mail, works only on the first account and does not work for any other accounts in the same profile. Work around: select each account's Inbox once and click on Get message. (Bug 85227)

    Mozilla does not warn the user of a low disk space condition. (Bugs 32443, 56565) Some symptoms you may see are:

    • Copying a message to your Sent folder fails entirely or may place incomplete copy in Sent folder.
    • POP: Status text indicates there are new messages to retrieve, but no new messages appear in the Inbox. Quit Mozilla , free some disk space, restart Mozilla , and try again.
    • IMAP: Status text indicates there are new messages to retrieve, but no new messages appear in the Inbox. Quit Mozilla , free some disk space, restart Mozilla , and try again.

    Mail account identity is not stored along with an unsent message. (Bug 59548)

    Linux: You may encounter problems if you install Mozilla in a root user environment then run as another user. Problems include saving to Sent folder, Drafts, Templates or general authentication problems. (Bug 49397)

    Mail notification sound doesn't play if an alternative sound is chosen: When the user edits pref.js to specify an alternative sound, then Mozilla will not play any sound when new mail arrives. Also changing it back to the default breaks the initial default sound for that profile. Workaround: Leave the pref.js setting for sound alone. (Bug 64462)

    The Mail & Newsgroups Account Settings dialog box does not display correctly at lower monitor resolutions such as 800 by 600 or 640 by 480. If possible, increase your monitor's display resolution above 800 by 600. (Bug 82122)

    AOL Mail and Netscape WebMail Accounts

    Mozilla does not integrate with AOL Mail and Netscape WebMail, as Netscape 6 does. If you share your Netscape 6 profile with Mozilla, you may be able to see headers for messages in the account's Inbox if you have previously checked one of these accounts in Netscape 6, but you will be unable to interact with the messages. To access your AOL Mail, WebMail, or Netscape Instant Messenger, you need to use Netscape 6.

    Receiving and Reading Messages

    You may not see the message header (From, Subject, Date, To, Cc, and so forth) when you read messages. This problem often occurs when you switch mail folders or newsgroups. To see headers, resize the window or the message content pane. (Bug 39655)


    In some cases you can't view more than one HTML/Web page attachment to a message in the mail window. The attachments will not all be shown or you may experience a crash when attempting to display them. (Bug 38398)

    Composing Messages

    You can't forward a message that has a signature file containing the HTML tag <div class="signature">. (Bug 49484)

    Address Book

    Imported Netscape Communicator address books appear in Mozilla as a separate address books. (Bug 41590)

    To import Outlook address books, you must have the default mail client set to "Microsoft Outlook" in Microsoft Internet Explorer. Do this:

    1. Launch Internet Explorer.
    2. Click Tools in menu bar, then click Internet Options. The Internet Options dialog box appears.
    3. Click the Programs tab and select "Microsoft Outlook" as the default e-mail client.
    4. Hit OK and exit Explorer. (Bug 90206)

    (Windows) You may need to try more then once before Outlook Express address books are imported successfully. (Bug 90206)

    Copying a large number of addresses between address books may cause crash. (Bug 82991)


    If you have multiple filters configured for a mail account, incoming messages will continue to be evaluated against each filter (in the order listed in the Message Filters dialog) until a filter action of Move to Folder or Delete is executed. This differs from Communicator 4.x where any filter action would stop further filtering on a message. (Bug 30081)

    Pop and IMAP

    You must exit and restart Mozilla to see the effect of a change to the option: "show All IMAP mail folders" or "show only subscribed IMAP mail folders." To access this option: click the Advanced button in the Server section of the Account Settings dialog box. (Bug 38943)

    When sending email from Cyrus IMAP mail accounts, you will get "The current command did not succeed. The mail server responded: Permission denied". Workaround: Redefine the special folder (sent, draft, template) under the Inbox folder. (Bug 27002)


    The Subscribe dialog box may not work with news servers that require authentication. If you open a password-protected newsgroup you may be prompted more than once for the user name and password combination.


    LDAP directories with ldif extensions may appear after migration from Communicator 4.x. (Bug 94645)

    Mozilla may temporarily hang during LDAP autocomplete if network connectivity is broken. Specifically, if the LDAP server in question is unreachable (network connectivity problems, including taking a laptop outside a firewall), the entire app will hang when attempting to contact that browser. If the user is patient, the app will begin responding again after the TCP timeout happens, probably between 30 seconds and several minutes later. (Bug 79509)

    Offline Mail

    Some mail items (offline and disk preferences, offline item selection, online/offline indicators in search/history/subscribe) do not display properly. (Bug 80970)

    Moving/Copying a downloaded message (while offline) will result in not being able to read the message at the new folder while you are offline. Workaround: Go online to read it, then re-download the message to have it accessible when you are offline. (Bug 78809)

    When starting Mozilla, if you only have one profile, both of the Offline preferences for startup mode ("Ask me if I want online or offline mode", or "Use my previous online/offline state") do not work. Mozilla will always start in online mode. To go offline, from the File menu, choose Work Offline. (Bug 82487)

    If the user starts Mozilla in offline mode (clicking the work offline checkbox in the profile manager), then tries to reply to a message while in offline mode, or double clicks on a message (which brings it up in a separate window), in some instances the application might crash. (Bugs 92368)

    When starting Mozilla, if you only have one profile, both of the Offline preferences for startup mode ("Ask me if I want online or offline mode", or "Use my previous online/offline state") do not work. Mozilla will always start in online mode. To go offline, from the File menu, choose Work Offline. (Bug 82487)



    ChatZilla is not finished, but is usable if you're willing to accept a subset of the commands offered in more mature IRC clients. A large percentage of ChatZilla users experience crashes, odd behavior, rash, shortness of breath, and an urge to fix bugs. If you would like to contribute, please tell us in the rginda@netscape.com.

    If you are not familiar with IRC, please check out the FAQs available at www.irchelp.org.

    Running ChatZilla

    Start Mozilla with the -chat option to start ChatZilla, or select it from the Window menu.

    More Info About ChatZilla

    See the ChatZilla User's Guide for information on using ChatZilla. For info on building ChatZilla, click here. (Note that ChatZilla builds automatically on Windows and Mac OS).

    JavaScript Debugger

    Profile data cannot be saved as HTML on Mac OS. If you see the error message "Cant match <!--@range-start-->", you're running into this problem. As a workaround, save as a CSV file and import into a spreadsheet, or save as plain text. (Bug 130050)

    Trying to save profile data when there is none to be saved results in the cryptic error message "summary has no properties". See (Bug 129692)


    When Publishing in Composer, if the Publishing URL, file name, user name, or password contain any special characters (such as "@") that need to be escaped, then Composer creates a duplicate site entry each time you publish the document. To work around this bug, choose the original site name from the Site Name list in the Publish dialog box before publishing the document again. For example, some ISP users have usernames that are also their email addresses, e.g., "janedoe@ispname.net". After publishing to this site, the next time you use the Publish dialog, the username from the document URL will appear as "janedoe%40ispname.net" (the "@" was escaped during publishing). Since Composer can't find this entry, it creates a duplicate site name. (Bug 141819)

    You may not be able to simultaneously edit a document using both Composer and another editor. (Bug 37089)

    You can't apply a font style across paragraphs and images. Font changes must be done within each paragraph.

    Applying a font style across several words yields multiple font tags in the HTML code.

    When the background color on a page is set, only the frames behind the lines of selected text are colored. Resizing the window triggers the proper repaint.

    After applying a color to text, the text may appear partially highlighted.

    Certain pages (such as ones that set frames) can't be edited. However, you are still able to choose the Edit Page option in the File menu for such pages. An editor window opens, but you are unable to edit the page.

    Edit|PasteAs function is not functioning. (Bugs 73286, 41547)

    File|Open Web Location, selecting to render in Composer does not open document in Composer. (Bug 71426)

    Switching between Normal and HTML Source mode inserts break (br) elements. (Bug 46227)

    You can not print HTML Source. (Bug 82239)

    Numerous shortcut keys do not function properly. (Bugs 26264, 48951, 57805, 70630, 58332, 58712, 26269, 53505, 76925, 57700, 67142, 4302, 48375)

    Hourglass does not show when application is busy. (Bug 83300)

    Some element icons do not render in Show All Tags mode. (Bug 88036)

    List editing can cause nested lists to outdent to next level list. (Bug 98547)

    Remove option from personal spell check dictionary does not work. (Bug 43348)

    If the cache preference is set to "Every time I view the page" and a new document is created, toolbar icons may be disabled on the toolbar and the caret may be missing. Workaround: Do not set the cache preference to "Every time I view the page." (Bug 97633)


    Restoring a certificate to a smart card can take a long time. No feedback is provided while restoring a certificate to a smart card, which can take a long time since smart cards are relatively slow devices. As a result, it may appear that the restoration is not happening. (Bug 52321)

    For security reasons, Mozilla does not allow connections to certain ports. To override this on a per-port basis, add a comma separated list of ports to default/all.js (in your Mozilla installation directory). Note that this pref only works in the all.js file in the Mozilla installation directory and it affects all users of the installation. It does not work if you add it to the prefs.js file in your personal profile directory. For example, to unblock ports 1, 3, and 7, use the following line:

    pref("network.security.ports.banned.override", "1,3,7");


    Do not share a profile between Netscape and Mozilla builds. Doing this can lead to unpredictable results, some of which may include loss of Search settings and preferences and unchecked growth of the Bookmarks file (large enough to freeze your system). It is best to create a new profile for each or manually copy (and change the name) an existing profile. (Bug 137164)

    If you are using the Classic theme, some preference panels may be displayed incorrectly or may have missing elements. If you view a different preference panel and then return to the one you're working in, the display is corrected. (Bug 51241)

    Preferences window initial size doesn't always give hints on all options available. Resize the window from its lower right corner to see them all. (Bug 53375)


    Plugins are not refreshed if the browser is restarted with QuickLanuch on. Workaround is to make sure Quicklaunch is not 'ON' by removing it from the system tray and then restarting the browser. (Bug 119056)

    Mozilla might crash while playing random Quicktime content. (Bug 136761)

    Windows: The Adobe SVG plugin crashes. Workaround: Don't copy it (NPSVG3.dll NPSVG3.zip) into your plugins folder. If you want to view SVGs, there are Mozilla builds with native SVG support. (Bug 133567)

    Linux: The Flash plugin context menu does not disappear when you clicks outside the plugin area to dismiss it. Workaround: Click inside the plugin to dismiss the plugin context menu. (Bug 63182)

    Linux: Mozilla will hang if a Flash plugin tries to play audio and the audio device is already in use. Workaround: Stop the audio device and return to that page. (Bug 58339)

    Linux: Mozilla crashes while playing Flash content on a remote X display. No workaround present other than not using remote X display. (Bug 58397)

    Linux: Loading a page that contains a Flash plugin may cause Mozilla to lock up if you are using an audio application. (Bug 58339)

    Plugins installed for Communicator 4.x may not be available for Mozilla . Workaround: install these plugins in the Mozilla Plugins folder.

    Linux: The flash plugin crashes when viewing a flash document on a remote X display. (Bug 58937)

    Windows: Microsoft Media Player file embedded in web pages may not work. (Bug 66015)

    Mac OS: Mozilla now scans for plugins in the system's "Internet Plugins Folder" first.


    Some users might not be able to print on Windows 98 or Windows ME with the default spool setting. The workaround is to go into printer properties, choose details tab, choose spool settings, and then choose print directly to printer. (Bug 130083)

    In Print Preview, plugins are not shown. (Bug 134002)

    Printing web pages may not print out all pages due to table pagination problems. (Bugs 87374)

    Mac OS and Linux: Transparent backgrounds are printed as black. (Bug 137114, 137115)

    Printing newsgroup messages with images leads to a crash. (Bug 92659)


    Mozilla has been tested with all 1.3.0_* versions of the JRE, and JRE 1.3.1, and beta versions of JDK 1.4. J2SE releases previous to 1.3.0_01 will not work with Mozilla .

    Running J2SE in 256 color mode may cause a flicking problem.

    Linux: LiveConnect support now works if you use Mozilla 1.0 Release Candidate 2 with JRE 1.3.1. Additional LiveConnect problems are being addressed in JDK 1.4 as mentioned above.

    Sun's JRE will crash at startup if your useragent does not begin with Mozilla/5. It might print

    Expected a version > 5! Version = 4
    The workaround is to not forge a useragent whose version is less than 5 if you have the Sun JRE plugin in your plugin directory. this preference would appear in pref.js as something like:
    user_pref("general.useragent.override", "Mozilla/4.0 (compatible; MSIE 5.0; Windows 98;)");
    (Bug 83376)

    If Java doesn't work, make sure the following is true:
    On Windows:
    Copy the NPOJI610.DLL from C:\JDK*\jre\bin to "\plugins" directory of your installation.
    On Unix:
    Make a soft link to /usr/java/j*/jre/plugins/i386/ns610/libjavaplugin_oji.so in your mozilla1.0.RC2 plugins/ directory.

    OS X

    On OS X, there is no "Default Downloader Plugin" (aka. the Default Plugin) and Java is not working yet. (Bug 88870)

    International Release Notes


    Mozilla has been designed to display many different languages without extra steps. The user should be able to browse and use e-mail without complicated setups or efforts when necessary fonts are available on the system.

    Mozilla can be used with more than one language pack, which lets the user change the menu language and relevant URLs.

    Contents of Sidebar tab and Bookmark will not change when you choose another region -- they are bound to a specific profile. (Bug 87939)

    If you are using Chinese, Korean or Japanese language Windows 9x/ME and launching fails or crashes, read the Java section of the Known issues section below for possible causes.

    You may be unable to print out Japanese characters from Win98-J with HP Laser Jet driver (Japanese version). Workaround: Install the driver that comes with the Japanese Windows 98 installation CD. (Bug 86989 )

    If you have WinME-Ja, you may not be able to print to a HP LaserJet 5Si/5Si MX using the HP LaserJet 5Si/5Si MX PS printer driver In this case, you should change the driver to HP LaserJet 5Si/MX. (Bug 86989)

    New: On platforms which support file names in Unicode, it is possible to create files and folders bearing names in scripts which fall outside of the system locale. Browser operations which involve such folder or file names may not succeed, e.g. saving into such a folder, or opening a file whose path contains such characters. Using only characters supported by the default system language avoids this type of problems. (Bugs 58866, 100243, 100344, 100364, 100396, 101573, 128380, 104305)

    General and Profile Manager

    On Japanese Windows XP, the desktop icon and Mozilla Program Folder cannot be removed after Mozilla program is removed through a program uninstallation via the Control Panel. You can manually remove them. (Bug 125104)

    Navigator and Composer

    Mozilla does not support Dynamic Fonts. (Note: It was supported in Communicator 4.x.)

    A window title (reflecting the title of a web page) may not show correctly if the web page (e.g. Japanese) does not match the language of the OS (e.g. English Windows). (Bug 9449)

    On Macintosh and OS/2 (i.e. non-Windows platform) Shift_JIS Full-width tilde character (0x8160) and a few other Japanese symbol characters have differing correspondences to Unicode mapping tables depending on platforms. These differences causes several difficulties on these platforms, e.g. form submisson, bookmarks, and sending mail. (Bug 108136.)

    The Character Coding menu doesn't work in a View Page Source window. You can change encoding in browser window and then view source. (Bug 136322)

    Auto-detect All/Universal may not be able to detect encodings on pages which don't supply document encoding information. You can increase the accuracy if you choose other auto-detection modules with a smaller scope for detection , e.g. Chinese, Simplified Chinese, East Asian.

    With the Windows 2000 IME, most of the new Japanese IME features (e.g. reconversion) are supported but some features may not work correctly. (Bugs 18680, 36975.)

    Support for the Unicode surrogate range is not currently available for Mac nor Linux. (Bugs 128263 and 127713.)

    A Composer page cannot be saved into ISO-2022-KR using the Save As ... menu because there is no converter available from Unicode to ISO-2022-KR. ISO-2022-KR will be eventually hidden in the Save as .. menu. (Bugs 132070 and 133615.)

    When opening a file under a folder with multi-byte folder name, the path name in multi-byte characters is escaped in the title bar of Composer window. (Bug 136221.)

    Linux only: Bold and Italics styles may not work on ASCII characters when editing a CJK page. This is most likely to happen on CJK locales without good ASCII fonts. For example, you may be using language open-source CJK locale support files. On commercial Linux distribution, particularly recent ones, the support files contain better CJK fonts and this problem is less likely to occur. (Bug 91145)

    Mac OS: Non-ASCII non-Latin 1 info stored in Internet Config will not show correctly in auto-fill fields such as "Your name" field in the Mail account setup dialog. If this happens, you can manually correct auto-filled entries. (Bug 5721

    Mac OS: The Character Coding menu check mark does not get updated promptly and shows incorrect indication of the current page encoding. (Bug 98625)


    Filtering by body key is not implemented.

    The Character Coding menu cannot correct the thread pane display of non-MIME encoded headers. This is by design. If the message displayed lacks MIME charset information, the thread pane display obeys the default message display charset set via the folder properties dialog (set via the menu Edit | Folder Properties ...). Correctly setting this option to the charset most often used in the user's mail viewing helps avoid display problem of this type


    Some cases have been reported in which Windows 9x/ME Japanese users have a problem starting Mozilla when there is a prior installation of older JDK or JRE under the operating system in use. The JRE 130_02 (or later) that Mozilla users can download from a Netscape ftp site contains many fixes since the official release of JRE 1.3. If you are using an older version of JRE 1.3 or the US version of JRE 1.3 under Japanese/Chinese/Korean Windows, you may experience this non-start problem.

    To determine if the non-starting problem is due to Java installation, follow these steps:

    1. Locate the Plugins directory (which is found in the same directory as the Mozilla executable).
    2. Remove all the Java plugin files from the Plugins directory, i.e. the files whose names begin with "npjava...". Remove also the NPOJI610.dll file if you find one. Back them up in another directory so that you can restore them later.
    3. Restart Mozilla . If Mozilla starts, then you have a Java related non-start problem.

    If you have the Java problem as described above or want to install updated JRE 130_02 (or later) that you can download from a Netscape ftp site, follow these steps (Note: This type of problem has not been reported for Windows NT4/2000, but if you experience this problem on the latter two platforms, follow these steps for those platforms also):

    1. Click the Start button, open the Settings menu, and choose Control Panel.
    2. Double click the Add/Remove Programs icon and select the Install/Uninstall tab.
    3. Locate the old JRE installation (Java Runtime Environment) and delete it.
    4. After the old JRE has been deleted, run Mozilla again. And go to any site that requires the use of Java. You will see a plugin-in icon on such pages telling you to click on the icon to download a Java Plugin.
    5. When you click on the "get Java Plugin" icon, you will be taken to a Netscape site to download a Mozilla plugin.
    6. Download the "International" version if you would like display of international characters. (recommended)
    7. Follow the instruction for the installer and complete Java 2 installation.

    Mac OS and Linux: Display of non-ASCII characters (particularly Chinese/Korean/Japanese) in applets may not work without correct font settings in font.properties files. Windows releases ship with modified font.properties files. This document may be helpful to Mac and Linux users.

    Using the Quality Feedback Agent with Automatic Proxy Configuration

    Windows: If you are using automatic proxy configuration, and you want to use the Full Circle Talkback Quality Feedback Agent to send incident reports to mozilla.org , you need to replace the talkback.ini file with one that contains the appropriate proxy configuration information. Follow these steps to do so:

    1. If you are using an HTTP proxy, or both an HTTP and SOCKS proxy, create a file named talkback.ini, containing the following three lines, using your proxy host name, domain, and port:


      where xxxx is your proxy port number.

      If you are using a SOCKS Proxy, create a file with these three lines:


      where xxxx is your SOCKS port number.

    2. Replace the existing talkback.ini file with the version you created.

    On Windows 95 and Windows NT systems, copy the talkback.ini file to the following directory location within the directory that contains the Mozilla.exe file: \Fullsoft\data\talkback.ini

    Setting User Preferences using prefs.js

    Mozilla is very configurable, and so there is not room in the UI for controls to change all the preferences. If you need to change a preference for which there is no UI, you will need to edit your preferences file, prefs.js. These instructions detail how to do this.

    This file is read in by Mozilla on startup, and rewritten on exit, so if you modify the file while Mozilla is running, your changes will get overwritten. So, first you must quit Mozilla completely (including quitting Quick Launch if you are on Windows). Once you have backed it up, open the prefs.js file in your profile directory and add the correct line or lines, which should have the form:

    user_pref("foo.bar.baz", "somevalue");
    user_pref("foo.bar.baz", true);
    for on/off preferences. When you have finished editing, restart Mozilla.

    Your profile directory is located at:

    • ~/.mozilla/<profilename>/xxxxxxxx.slt/ on Unix
    • %WINDOWS%\Application Data\Mozilla\Profiles\<profilename>\xxxxxxxx.slt\ on Windows
    • Documents:Mozilla:Profiles:<profilename>:xxxxxxxx.slt: on Mac OS.
    xxxxxxxx.slt is a randomly generated directory name. It's an important security feature.

    Notes For Web Developers

    For a list of known issues with support for Web standards (HTML 4.01, CSS1/2, DOM1/ 2, XML, RDF), JavaScript, Java, and Plug-ins in Mozilla, see the following documents:

    When a page using a strict document type declaration (e.g. HTML 4.01 Strict) links to an external style sheet (using <link>, @import, etc.) Mozilla will load the style sheet only if it is served with a MIME type of "text/css". Style sheets served with other MIME types, like text/plain, application/x-pointplus, etc. will not be loaded. To add the proper CSS MIME type to an Apache web servers, add "text/css css" to the system mime.types file. Or if you can't do that, add "AddType text/css .css" to your .htaccess file.

    How To Get Involved With Mozilla

    • Join us on Bug Day. If you want to help test Mozilla, but don't know where to start, join us on thursdays and fridays on the #mozillazine (Java IRC Client) IRC channel on irc.mozilla.org. There you can meet friendly Mozillans who can help you learn the process and get you started.
    • Join the Bug-A-Thon. If you can script, you can help simplify test cases.
    • Join mozilla evangelism (#evangelism), the project of the Mozilla organization dedicated to ensuring websites are compliant with web standards.
    • To become even more involved, check out these suggested starting points.

    Where To Find Other Builds

    • Download the latest major release of Mozilla from mozilla.org.
    • Download today's build of Mozilla from the mozilla.org FTP site.
    • Learn how to build Mozilla yourself.
  • Copyright © 1998-2002 The Mozilla Organization.
    Last modified May 10, 2002.
    Document History.
    Edit this Page